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Web Accessibility Guidelines
Headings
· Use properly formatted headings to structure a page. 
· Why is this important? 
· Headings help to organize content, making it easier for everyone to read. Headings are also a primary way for people using screen reading software to navigate a page of text. 
Lists
· Format lists as proper lists 
· Why is this important?
· Formatting is conveyed to assistive technologies and mobile devices so they can present information as it’s meant to be presented. Properly formatted documents are more understandable and accessible. 
Links 
· Write meaningful link text. 
· Why is this important? 
· Links embedded in text should describe the link’s destination. This helps all users navigate more efficiently, especially screen reader users. 
Tables
· Create tables with column and/or row headers, and ensure a proper reading order.
· Why is this important? 
· Column Headers
· Using table headers in important to conveying tabular data accurately. 
· Reading Order 
· Screen readers read tables from left to right, top to bottom, one cell at a time (and only once). If cells are split or merged, it could throw the reading order off which may make the table difficult to comprehend by users who are blind and using a screen reader to navigate. 
Color
· Use sufficient color contrast 
· Don’t use color alone to convey meaning. 
· Why is this important? 
· Without sufficient color contrast between font and background, people who are color blind and low vision will not benefit from the information. And using color alone to convey meaning will leave those who are color blind or blind unable to interpret the meaning. 
Keyboard
· Ensure that any action that uses a mouse can also be completed using only the keyboard.
· Why is this important? 
· Mobility and visual disabilities often make a mouse impossible or ineffective. If content is not keyboard accessible, it will limit who learn from the content. 
Images
· Provide alternative (Alt) text descriptions for images. 
· Why is this important? 
· Alt text is read by a screen reader. It should adequately describe what is being displayed and why it’s important. This allows the screen reader users to benefit from the information being conveyed by the image, even if they cannot see it. 

How to Make Accessible D2L Web Pages
Page Template 
· Use the most current D2L page template. 
· How to make it accessible? 
· If you don’t have the most current page template, contact the Faculty Help Desk or your campus Instructional Technology Specialist (ITS). 
Headings 
· Properly format headings. 
· Use headings in the correct order. 
· How to make it accessible? 
· Highlight the text and select the heading number from the Format drop-down menu on the tool bar. 
· There should be only one Heading 1 (h1) per page, but there can be multiple h2, h3, h4, h5, h6. DO NOT skip heading levels. 
Images
· Add Alternative (Alt) text to images. 
· How to make it accessible? 
1. Place the cursor where you want to insert an image, and click the Insert Image icon from the toolbar. The Add a File window will open. 
2. Browse to the image location and select the image file. Click Add button. 
3. The Provide Alternative Text window will open. Describe the purpose of the image in the Alternative Text field, or just check the box if the image is just decorative. 
4. Click OK.
Lists 
· Format a list as a list using Ordered or Unordered lists. 
· How to make it accessible? 
1. Select the content you want to make into a list. 
2. From the toolbar, click the Unordered/Bulleted list icon if the order doesn’t matter. Select Ordered List if from the drop down menu (next to the bulleted list icon) if the order does matter. 
Links 
· Write meaningful link text that indicates the link’s destination. 
· How to make it accessible? 
1. Highlight meaningful text for the link (ex. Portland Community College) 
2. From the toolbar, click on the Insert Quicklink icon. 
3. Select URL in the Insert Quicklink window
· Type in the URL
· Select New Window in the Target section. 
4. Click the Insert.


How to Make Accessible D2L Web Pages 
Tables
· Indicate column (or row headers) in data tables
· How to make it accessible? 
1. Select the cells to be marked up as a row or column header.
2. Click on the drop-down menu next to the Table icon in the toolbar. 
3. Choose Cell Properties. The Table cell properties window will open. 
4. In the Cell Type field, click on the drop-down list and select Row Header or Column Header. 
5. Click Update button. 
· Add table caption. 
· How to make it accessible? 
1. Select the table and click on the drop-down menu next to the Table icon. 
2. Select Table Properties, and check Include Caption. 
3. Click Update when done.
· Check the reading order.
· How to make it accessible?
· A screen reader reads tables from left to right, and top to bottom, never repeating a cell. 
· Merged, nested, and split cells may alter the reading order of a table. 
· Make sure you construct your tables in a way that accommodates a good reading order.
Color
· Use sufficient color contrast. 
· How to make it accessible? 
1. Select the text that you want to change to another color. 
2. Click the drop-down menu next to the Apply Color icon in the toolbar. 
3. Select the color and click Save. 
Note: When picking a color for your text in D2L, make sure you choose a color that registers with a green checkmark for WCAG AA in the Select a Color palette. 
· Don’t use color alone to convey meaning. 
· Don’t use color alone to make a distinction, a comparison, or to set something apart from the rest of the web page. If you categorize something by color alone, those who are color blind or blind will not benefit from the color distinction. 
Math and Science 
· Write math and science equations using MathML. 
· How to make it accessible? 
· Use the D2L equation editor. For more information, go to the math and science section of this handbook. 
Multimedia
· Eliminate or limit blinking/flashing content to 3 seconds. 
· Make sure all mouse actions can also be completed with a keyboard alone (without a mouse). 
· Use an accessible media player like YouTube or the DL Kaltura Player. 
How to Make Accessible PowerPoints and Google Slides 
Outline View 
· PowerPoint 
1. Click on the View tab (Mac: View > Outline View icon-PPT 2016.)
2. In the Presentation Views group, click on Outline View. 
3. In the Outline panel, make sure all text from the slides appears in the Outline View. 
· Google Slides 
· There is no Outline View in Google Slides. 
Slide Layout
· Use the PPT provided slide layouts when building slides to help your slide’s reading order remain intact
· PowerPoint 
· From Home tab, choose the New Slide drop-down menu and select a slide template. (Don’t use the Blank Slide template.) 
· Google Slides
1. Create a new slide (Slide > New Slide). 
2. Go to Slide menu, click on Apply Layout and choose one of the slide templates. 
Reading Order
· Ensure the tab order = the reading order
· PowerPoint 
1. On the Home tab, click on Arrange and choose Selection Pane (Reorder Objects for Mac – PPT 2011 and 2016). 
2. To see the reading order of the slide, tab through the slide and the corresponding element will highlight. 
3. To re-arrange the reading order, click arrow up/down button on the Selection Pane (Mac: Drag layers. Highest number is read first.)
4. Test reading order with the Tab key again. 
· Google Slides 
1. Tab through the slide and the corresponding element will highlight. 
2. In the slide area, click on the element that you want to change. 
3. To change the reading order, click on Arrange menu > Order. Send backward will raise the element to a higher reading order. Bring forward will make the element lower in the reading order 
4. Test reading order with the Tab key again. 
Images 
· Add alternative (alt) text to images and shapes. 
· PowerPoint
1. Right click on the image and select Format Picture. 
2. Click on the square icon with arrows in it to open the Alt Text field. 
3. Enter appropriate alt text in the Description field (not the Title field.)
· Google Slides 
1. To insert an image, choose Image from the Insert menu and follow the instructions. 
2. To add Alt text, click on the image. Then in the format menu, select Alt Text (at the very bottom of the menu). 
3. Enter alt text in the Description field (not the Title field). 
How to Make Accessible PowerPoints and Google Slides
Lists 
· Format a list as a list 
· PowerPoint 
1. Select the text to make into a list and click on the Home tab. 
2. In the Paragraph group, select the numbering or bullets icon. 
· Use numbering lists if a sequential order is important to the list.
· Use bullets lists if all items are of equal value.
· Google Slides 
1. Go to the Format menu > Lists and select one of the list styles. 
Links 
· Create a meaningful link that describes its destination. 
· PowerPoint 
1. Type out text that describes the destination of the link (i.e. PCC Homepage) 
2. Select the text, right click and choose Hyperlink from the menu 
3. The Insert Hyperlink window will open. Enter a URL address in the address field. 
4. Click the OK button to save the link. 
· Google Slides 
1. Type out text that describes the destination of the link. 
2. Select the text, right click and choose Link from the menu. 
3. Paste or type in a hyperlink. 
4. Click Apply button to save the link. 
Tables 
· Check the reading order. 
· A screen reader reads a table from left to right and top to bottom (never repeating a cell.)
· Merged, nested, and split cells may change the reading order of a table. 
· Construct your table in a way that accommodates a good reading order. 
· Indicate column headers for data tables. 
Note: A table in slide show view is not accessible. Use Alt Text! 
· PowerPoint 
1. Place the cursor in the top row of your data table. 
2. Click the Design tab under Table Tools (Mac - PPT 2011/2016: Tables tab)
3. In the Table Style Options group (Mac - PPT 2011 - Table Options > Options / Mac - PPT 2016 - Table Design tab), select the Header Row check box.
4. The cells in the top row of your table make up the column headers.
· Google Slides 
· You cannot create table column/row headers in Google Slides.


How to Make Accessible PowerPoints and Google Slides 
Color 
· Use sufficient color contrast.
· Use enough color contrast between the text (i.e. black color) and the background color (i.e. white color).
· Without sufficient color contrast, people who are low-vision and color blind will not benefit from the information.
· Don't use color alone to convey meaning.
· Don't use color alone to make a distinction. If you categorize something by color alone, those who are color blind or blind won’t benefit from the information.
Math and Science 
· Use MathType to write Math equations.
· PowerPoint 
· Use the MathType plugin for MS Word to create math and science equations, formulas and notations. (DO NOT use MS equation editor.)
· Google Slides 
· MathType plugin is also available to install on Google Docs. Follow steps for alt text on images, a descriptive title and then the equation written out in the description is best.
Video and Audio 
· Don’t embed the video, instead, link out to videos.


How to Make Accessible Word Documents and Google Docs
Headings 
· Properly format headings.
· Word Document 
1. Select the text that you want to make into a heading.
2. Go to the Home tab.
3. Choose the appropriate heading level from the Styles group.
· Google Docs 
1. Select the text that you want to make into a heading.
2. Go to the Styles menu (or "Normal text") and choose the appropriate heading level from the Normal text drop down list.
· Use headings in the correct order. 
· Heading 1 should only be used ONCE per page. Heading 2, 3, etc. can be used multiple times. (DO NOT skip heading levels!)
Images 
· Add alternative (alt) text to images.
· Word Documents 
1. Right click on the image, and select Format Picture.
2. The Format Picture window will open.
3. Click on the square icon with arrows in it to open the Alt Text field. 
4. Enter image description in the Description field (Not the Title field.)
· Google Docs 
1. Select the image.
2. From the Format menu choose Alt text.
3. Type in description text in the Description field. (NOT in the Title field.)
4. Click the OK button when done.
Lists
· Format a list as a list. 
· Word Document
1. Select the text that you want to make into a list.
2. On the Home tab, in the Paragraph group, select the Bullets or Numbering list.
· Google Docs
1. Select the text that you want to make into a list, and do one of these:
a) On the Format menu, choose Lists & select Numbered or Bulleted list.
b) Go to the icon toolbar, and choose the Numbered or Bulleted list icon.



How to Make Accessible Word Documents and Google Docs Links
· Create a link that describes its destination.
· Word Documents 
1. Type out text that describes the destination of the link. (i.e. PCC).
2. Select the text, right click and choose Hyperlink from the menu.
3. The Insert Hyperlink window will open. Enter a URL address in the Address field (Mac - Word 2011: Link to field.)
4. Click the OK button to save the link.
· Google Docs 
1. Type out text that describes the destination of the link (i.e. PCC).
2. Select the Insert link icon.
3. The Link window will open. Type the URL of the webpage in the Link field.
4. Then click the Apply button to save the link.
Math and Science
· Word Documents
· Use the MathType plugin for MS Word to create math and science equations, formulas and notations. DO NOT use Microsoft's equation editor.
· Google Docs
· MathType addon is available for Google Docs. This addon creates a single image with a title and descriptive text from what is inserted in the text box, follow steps for making images accessible.
Tables
· Indicate column headers for data tables.
· Word Documents
1. Place the cursor in the top row of your data table.
2. Click on the Design tab under Table Tools (Table tab on Mac - Word 2011/Table Design tab - Word 2016).
3. In the Table Style Options group, select the Header Row check box.
4. Under Table Tools, click the Layout tab (Table Layout tab - Word 2011)
5. In the Data group (Word 2016 - Table Design > Layout tab), click the Repeat Header Row button. This will indicate the top row as the table's header.
· Google Docs 
1. Use tables for presenting data, not for changing the visual layout of the page. In the table, include a heading row (rather than starting with data in the first row) because screen readers automatically read the first row as a heading row.
· Check the reading order.
· Screen reader reads a table from left to right/top to bottom (never repeating a cell.) 
· Merged, nested, and split cells may change the reading order of a table. 
· Construct your table in a way that accommodates a good reading order. 
· To test the reading order, place your cursor in the first cell of the table. On the keyboard, press the Tab key repeatedly to navigate through the table. This will be the reading order that assistive technologies will use.


How to Make Accessible Word Documents and Google Docs
Color
· Use sufficient color contrast.
· Use enough color contrast between the font and its background colors.
· Without sufficient color contrast, people who have low-vision or are color blind will not benefit from the information. 
· Don't use color alone to convey meaning.
· Don't use color alone to make a distinction. If you categorize something by color alone, those who are color blind or blind will not be able to benefit from the information.
Forms
· Label form fields and buttons.
· Word Documents
· Use a form template to create a form.
· Use real text labels for form fields and alternative text for buttons.
· Google Docs
· Use Google Forms, NOT Google Docs.
· Check the reading order of forms.
· Press the tab key repeatedly to check the order a screen reader would navigate through the form. If it doesn’t land on the form fields in the correct order, you will need to edit the form. 
· The tab order (or reading order) is important to those who are blind or physically disabled and rely on keyboard access.

How to Make Accessible PDFs
Convert MS Office into an Accessible PDF Document 
· Use Microsoft Office 2010, 2013 Pro
1. Start with a well-structured Word document or presentation.
2. Click the File tab and select Save As. In the Save As type field, select PDF (*.pdf.)
3. Enter a file name in the File name field.
4. Click on the Options button and make sure the Document structure tags for accessibility and Create bookmarks using Headings checkboxes are checked.
5. Click OK and Save. This will tag all of the text formatting, so page headings and lists are correctly interpreted by a screen reader.
Save Your Original Files (PPT, Word) 
· Use MS Office 2011 (for Mac) 
· Microsoft Word & PowerPoint 2011 for the Mac cannot produce a fully accessible PDF. 
· Use Portland Community College’s resources for options on how to create an accessible PDF.
Run Optical Character Recognition (OCR) on scanned Document 
· Use Adobe Acrobat Professional (Version XI Pro)
1. Open the scanned PDF file.
2. Open the Tools panel (click Tools in top right) and click Text Recognition.
3. Click In This File and the Recognize Text window will open.
4. Click the Edit button to adjust OCR settings. Select English (US) for Primary OCR Language, Searchable Image for PDF Output Style and 600 dpi for Downsample To.
5. Click OK when done.
Run Adobe Acrobat Built-In Accessibility Checker 
· Use Adobe Acrobat Professional (Version XI Pro)
· Click the Tools tab to open the Accessibility panel on the right hand side. 
· If you don't see it, click the View menu and select Tools > Accessibility.
· Under Accessibility, select the Full Check button.
· The Accessibility Checker window will open.
· Under the Report Options, check on the Create Accessibility Report.
· Under the Checking Options section:
· Category: Document and check all the items.
· Click the Start Checking button.
· The Accessibility Checker Report will display on the left pane.
All versions: no matter what you are converting to PDF, it’s important to save your original files in case a student needs an alternate format.


How to Make Accessible Video and Audio 
Media Player
· The buttons need to be properly labeled so a screen reader can operate the player. 
· Keyboard Navigation
· It is important to accessibility that students can access and operate a media player with the keyboard alone (not using a mouse).
· How to make it accessible? 
· To test for keyboard accessibility, press the Tab key to navigate to the player, and use the Tab, Arrow keys, Enter, and Spacebar to interact with the media player buttons.
Captioned Media
· We recommend you first search for captioned media, but you are not required to use only captioned media. Use the best media for your lesson. Uncaptioned media will be accommodated at the time of need.
· Search for captioned media
· How do I find human transcribed captioned videos on YouTube? (Search from YouTube site)
1. Enter your search keyword in the YouTube Search field.
2. Add a comma then “CC”
3. Press Enter or click the magnifying glass icon.
· How do I find human transcribed captioned videos from Google?
1.  Fill out the Advanced Video Search fields that you need.
2. Choose the "Subtitles: Closed captioned only" option.
3. Press Enter or click the Advanced Video search button.
· Make sure the YouTube Video you use is NOT Auto-Generated. 
· How do I know? 
· Click the Settings button and check the Subtitles field. Avoid auto-generated subtitles and the Translate feature which are not usually accurate.


How to Make Accessible Complex Images
Complex Images
Include graphs, charts, diagrams, maps, and illustrations. Below are 3 ways to provide alternative (alt) text-based description for complex images, when a simple alt text attribute is insufficient. Choose the best Alt text method for your image types.
Use a Caption
· For Web Pages
· Your caption must be associated with the image, so make sure to properly add a caption using the 'figcaption' html tag. (Requires HTML editing). 
Note: For MS Word and PowerPoint: Right click on the image and select Add Caption.
Describe in Surrounding Text 
· If the image is adequately described in surrounding text (including text-based data tables), so that the image is just reinforcing the text, no further description is necessary.
Link Out to a Web Page with a Longer Description 
· If the image cannot be described using methods A or B, use the 'longdesc' attribute (Requires HTML editing).
Resources for Image Description 
· Guidelines for Describing STEM (Science Technology Engineering and Math) images
· How Do We Access Meaning in Art? (Describing art images in alt text).
· Video: How to Describe Complex Images for Accessibility (From Diagram Center's Webinars)
· Diagram Center's Accessible Image Sample Book



How to Make Accessible Math and Science
MathML
· MathML stands for 'Math Markup Language' which is the web standard for accessible online math and science notation/equations/formulas. Typically, a user does not create MathML, but instead uses a conversion process to output MathML.
D2L
· We recommend that as much of the online class as possible be conducted within D2L. All output from D2L’s equation editor is stored as MathML, which is screen reader-accessible.
Word Documents 
· MathType is an equation editor created by Design Science that is compatible with MS Word for Windows and Mac. Together, MS Word with MathType can be exported as MathML or it can be converted to braille. (Save your original files.) DO NOT use Microsoft’s equation editor.
PDFs
· Math IS NOT accessible in PDF. Save the original file with the original MathType or LaTeX equations. Center for Student Access will ask for your original files when there is an accommodation need.
PowerPoints
· For MS PowerPoint 2013, use the MathType 6.9 plugin or later to create math and science equations, formulas and notations. DO NOT use Microsoft's equation editor. If you convert to a PDF or export to a webpage, save your original MS PowerPoint files which Center for Student Access may ask for.
Graphs
· To make graphs accessible, do your best to describe them using alternative text, long descriptions, or captions.  We can supplement with tactile graphics if necessary.
LaTeX
· LaTeX is a mark-up language. Converting LaTeX documents into an accessible format is usually straightforward. Keep LaTeX original files if you convert to other formats.
WeBWorK
· WeBWorK is an accessible and free online homework platform for math and sciences courses.
LibreOffice
· LibreOffice (with its native equation editor) exports easily to web pages that contain MathML.

Linking to 3rd Party Online Materials 
Ask: How Accessible Are Their Digital Materials? 
· Questions and Considerations:
· Are the video and audio recordings transcribed? 
· There should be transcripts for audio recordings and captions or subtitles for video. If they aren't available, ask the publishing representative when they plan to have them. If they have no plans, ask them to give LCC written permission to transcribe or caption the media when there's an accommodation need. 
· Are images described in alternative text? 
· PowerPoint slides from publishers often have images without any alt text. Ask your publishers if their images have alt text. 
· Can all of the text that is displayed on the screen be read aloud by text-to-speech software? 
· Screen readers (assistive technology used by people who are blind) read real text. They cannot read images of text or text embedded in Flash animations/movies/simulations. 
· How accessible are the E-books? 
· Are the images described? Are embedded objects like videos keyboard accessible and captioned? Is the E-reader keyboard and screen reader accessible? 
· Can all interactivity (media players, quizzes, flashcards, etc.) function using only the keyboard (no mouse)? 
· People who are blind or have upper mobility disabilities cannot use a mouse. They use the keyboard to navigate and interact on the Web. It is required that any interactive elements on a publisher's website (or on a DVD included with the book) be operable by keyboard alone if they are used in your course. 
· Is there any documentation available (VPAT or White Paper for example) that confirms accessibility or usability testing results? 
· A VPAT (Voluntary Product Accessibility Template) is used by many organizations to report the level of accessibility of software products. 
· Is your multimedia (Adobe) Flash or (Oracle) Java-based? Can your materials be watched on mobile devices? 
· Content created in Flash or Java can be inaccessible and may not run on mobile devices and tablets, which are becoming more prevalent. 
· What are the computer requirements for using their materials? Will the materials work on mobile devices?
· Distance Learning informs online students about the computer requirements for taking an online course in the Distance Education Orientation for students. If your course requirements are different, make them known in the course syllabus.
Open Educational Resources (OER)
· Questions and Considerations:
· OERs have the same accessibility requirements as all other digital materials. However if they are not accessible, we can usually retrofit them to be accessible which we can't do if the materials reside on a publisher's server. Plus OERs are usually free to students!

Automated Accessibility Checkers
MS Offices 2010 and 2013 Windows (Word, PowerPoint)
· A built-in accessibility checker
Note: The accessibility checker only checks .docx and .pptx files
· How to check:
1. Go to the File tab.
2. Select Info from the sidebar menu.
3. Click on the Check for Issues button.
4. Select Check Accessibility from the drop-down list.
· The Accessibility Checker panel will open to the right of the document. The accessibility checker provides you with a list of errors, warnings & tips. When you click on an error or warning, instructions on how to fix it appear below in "Additional Information".
PDF (Adobe Acrobat XI Professional)
· A built-in accessibility checker 
(View > Tools > Accessibility)
· How to check:
· Click the Tools tab to open the Accessibility Tool panel on the right. (If you don't see it, click the View menu and select Tools > Accessibility).
· Select the Full Check button & the Accessibility Checker Options will open.
· On the Report Options section, check on Create Accessibility Report.
· On the Checking Options section: select Document under Category field, and check all items.
· Click on the Start Checking button and the Accessibility Report will display.
D2L and Web Pages 
· A browser-based checker, WebAIM WAVE accessibility add-on to the Firefox browser
· How to check: 
· Download & Install the WAVE toolbar. 
· Open the D2L page in its own window by clicking on the Open in a new window icon.
· Right-click on the page in the new window, and select WAVE, then choose "Errors, Features, and Alerts" to see what accessibility errors you have on the page.
· Error icons in green, red, yellow and blue will appear on the page. If you hover over an error icon, more information on the error will appear.
· Return to the original D2L page, and open the D2L editor to repair the problems you found.
[bookmark: _GoBack]For more resources to make course materials accessible, go to the Accessibility tab on the Center for Teaching Excellence website. 
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